Mac Superdrive question

HankScorpioHankScorpio 163 Posts
edited August 2006 in Strut Central
Hello Lads,Last night I had some trouble with my G4 Powerbook - the problem is resolved but I don't know what happened in the first place or how to prevent it from happening again.I had set up a playlist to burn in iTunes and when I inserted a CD the Superdrive didn't grab the CD. Hmmm. I didn't try to force it in, I did as normal - put part of the CD in and let the drive grab it - but there was no grabbing. The CD would not go in.I went into System Profiler and it didn't show that I had a Superdrive. Interesting. I restarted the computer, and again went into System Profiler. Still no Superdrive.I shut down, then started up. I heard the Superdrive make noise like it was ejecting a CD. To my relief, System Profiler showed that I had a Superdrive. I inserted a CD, the drive took it, and a few minutes later my CD was done.A visit to the Apple support forums found other people with a similar problem, but on the Mac Mini - and no resolutions that I found.One thought is that the ATA drive could potentially be failing in 1 of 3 places, with varying degrees of expense.I know they are some Mac users on the forum and any help would be much appreciated.


  • white_teawhite_tea 3,262 Posts
    I had a similar problem with an '03-era Powerbook. It was just a regular combo drive, but every once in a while it would make a lot of noise and then act normal again. I want to say it was caused by me putting in a CD sideways, like at the wrong angle. But I don't know.

    I eventually dropped the laptop on the ground and had to replace the hard drive (to the tune of about $1,000). They replaced the drive for free. Problem solved!

  • Thanks for the reply. I bought it in March of 05. What throws me is that it was working fine the last time I burned CDs and I didn't do anything different this time. So how it just 'lost' the fact that I have a Superdrive installed has me baffled.

    Needless to say I'm crossing my fingers.

  • white_teawhite_tea 3,262 Posts
    Maybe the connection is a little loose inside the computer?

  • That's a possibility ... probably the least expensive of the possibilities, at that.
Sign In or Register to comment.